Mes cours

Ils s’agit de mes cours de développement.

  • Les types 
    Algo : entier, réel, boolean, caractère, chaine.
  • C : int, long int, short int, unsigned, float, double, char (chaine est un tableaux)
  • PHP : la valeur de la variable définit son type.

Les variables : 
  • Algo → nomVariable : type;
  • C → type nomVariable;
  • PHP → $nomVariable;

Les entrées / sorties : 
  • Algo → saisir / afficher
  • C → scanf / printf
  • PHP → echo / print ( pour saisir utiliser les opérations : +, -, *, /, %, ++, –, *=, -=, /=, +=.

Écrire un Algo, un programme C et un PHP qui permet de saisir les côtés d’un rectangle et affiche la surface et le périmètre.

 

Algo:

Déclaration
            lg, lr, p, s : réél
Début
Afficher (“Donner la longueur :”)
Saisir (lg)
Afficher (“Donner la largeur :”)
Saisir (lr)
p ← (lg + lr) *2
s ← lg * lr
Afficher ( “Le périmètre est de :”, p)
Afficher ( “La surface est de :”, s)
Fin rectangle

Programme C:

#include <stdio.h>
int main (){
            float lg, lr, p , s;
            printf(“Donner la longueur”);
            scanf(“%f”, &lg);
            printf(“Donner la largeur”);
            scanf(“%f”, &lr);
            p = (lg +lr) * 2;
            s = lg + lr;
            printf(“Le périmètre est de %f”, p);
            printf(“Le périmètre est de %f”, s);
return 0;
}
 

PHP:

<!DOCTYPE html>

<html>

<head>
            <title>Exo rectangle</title>
            <meta charset=”utf-8″>
</head>
            <body>
                        <form action=”” method=”POST”>
                                   longueur : <input type=”text” name=”lg”>
                                   largeur : <input type=”text” name=”lr”>
                                   <input type=”submit” name=”valider” value=”valider :”>
                        </form>
                        <?php
                        if(isset($_POST[‘valider ‘])){
                                   $lg = $_POST[‘lg’];
                                   $lr = $_POST[‘lr’];
                                   $p = ($lg + $lr) * 2;
                                   $s = $lg * $lr;
                                   printf(‘Le perimètre est de %f’, $p);
                                   printf(‘La surface est de %f’, $s);
                                   echo (‘Le perimètre est de %f :’ . $p);
                                   echo (‘La surface est de %f :’ . $s);
                        }
            ?>

            </body>
</html>

 

 

ecrire un algo, prog C, dèv PHP qui permet de résoudre dans R l’équation du premier degré a*x = b = 0.
Algo : equation 
Declaration 
a, b, x : réél
Debut
afficher (“Donner le premier coef : ”)
saisir (a)
afficher (“Donner le deuxieme coef : ”)
saisir (b)
Si a = 0
            Alors Si b = 0
                        Alors Afficher (“Ens solutions est R”)
                        Sinon Afficher (“Ens solutions est vide)
Finsi
Sinon
            x ← -b/a
            Afficher(“Solution est : ”, x)
Finsi
Fin Equation
———————-
C : 
#include <stdio.h>
int main (){
            float a,x, b;
printf(“Donner a : “);
scanf(“%f”, &a);
printf(“Donner b : “);
scanf(“%f”, &b);
if(a==0){
            if(b==0){
                                   printf (“l’ensemble des solutions est R\n”);
                                   } else {
                                   printf (“l’ensemble des solutions est vide\n”);
                                   }
                                   } else {
                                   x =  -b/a;
                                   printf(“Solution est : %f\n”, x);
                                   }
return 0;
}
——————————–
<html>
           <head>
                        <title>Equation</title>
                        <meta charset= «utf-8 »>
           </head>
<body>
           <form action= « » method= « POST »>
                        Coef 1 : <input type= « text » name= « a »>
                        Coef 2 : <input type= « text » name= « b »
                        <input type= « submit » name= « submit »>
           </form>
< ?PHP
           if ( isset ( $_POST))  {
                       $a = $_POST[‘a’] ;
                       $b = $_POST[‘b’] ;
If ($a==0) {
           if ($b==0) {
                        printf (« l’ensemble des solutions est R ») ;
           } else {
                        printf (« l’ensemble des solutions est vide ») ;
}
           } else { 
                                   $x = -$b/$a ;
           printf (« Solution est :%f », $x) ;
           }
}
 ?>
</body>
</html>
______________________________________
Les boucles : 
  1. Tant que
                                   Algo : Tant que condition faire  
                                               Instruction
                                               fin tantque
                                   C et PHP : 
                                               while (condition)  {
                                                           instruction ; 
                                               }
  1. faire tantque
                                   Algo : faire
                                               instruction
                                               tantque condition
                                   C et PHP : 
                                               do {
                                                          instruction ;
                                               } while (condition) ;
  1. la boucle Pour
           Pour indice allant de VD à VF pas de Pas faire
                       instruction
           finpour
C et PHP : 
for (initialisation ; condition ; evolution)
{
           instruction ; 
}
___________________________________________________
Exo 1 : écrire un Algo, un prog C, dév PHP qui permet de saisir un entier et affiche ses diviseurs.
Exo 2 : écrire un Algo, prog C, dév PHP qui permet d’afficher tous les nombres parfaits compris entre deux limites fixées par l’utilisateur.
Un nombre est dit parfait s’il est égal à la somme de ses diviseurs sauf lui-même.
___________________________________________________
Algo : Diviseurs 
Déclaration
            nb, div : entier
Début
            afficher (“Donner un nombre: ”)
            saisir (nb)
            pour div allant de 1 à nb faire
                        si nb % div = 0 
                                   alors afficher (div, “est un diviseur”)
                        finsi
            finpour
Fin Diviseurs
___________________________________________________
En C : 
#include <stdio.h>
int main {
            int nb, div;
printf(“Donnez un nombre”);
scanf(“%d”, &b);
for (div = 1; div<=nb; div++)
{
if (nb % div == 0)
{
printf(“%d est un diviseur”, div);
}
}
return 0;
}

 

 

 

 

 

 

 

 

 

Les boucles : 

  1. Tant que

                                   Algo : Tant que condition faire  

                                               Instruction

                                               fin tantque

                                   C et PHP : 

                                               while (condition)  {

                                                           instruction ; 

                                               }

  1. faire tantque

                                   Algo : faire

                                               instruction

                                               tantque condition

                            

                                   C et PHP : 

                                               do {

                                                          instruction ;

                                               } while (condition) ;

  1. la boucle Pour

            Pour indice allant de VD à VF pas de Pas faire

                        instruction

            finpour

C et PHP : 

for (initialisation ; condition ; evolution)

{

            instruction ; 

}

___________________________________________________

Exo 1 : écrire un Algo, un prog C, dév PHP qui permet de saisir un entier et affiche ses diviseurs.

Exo 2 : écrire un Algo, prog C, dév PHP qui permet d’afficher tous les nombres parfaits compris entre deux limites fixées par l’utilisateur.

Un nombre est dit parfait s’il est égal à la somme de ses diviseurs sauf lui-même.

___________________________________________________

Algo : Diviseurs 

Déclaration

            nb, div : entier

Début

            afficher (“Donner un nombre: ”)

            saisir (nb)

            pour div allant de 1 à nb faire

                        si nb % div = 0 

                                    alors afficher (div, “est un diviseur”)

                        finsi

            finpour

Fin Diviseurs

___________________________________________________

En C : 

#include <stdio.h>

int main {

            int nb, div;

printf(“Donnez un nombre”);

scanf(“%d”, &b);

for (div = 1; div<=nb; div++)

{

if (nb % div == 0)

{

printf(“%d est un diviseur”, div);

}

}

return 0;

}

Tous nos projets web commencent ici